Elevated Processing Times US Region

Incident Report for Cytora

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 09:33 GMT

Monitoring

All queued jobs are now being processed.

We continue to monitor.
Posted Jan 21, 2026 - 00:39 GMT

Update

We have applied mitigation and processing times are reducing towards normal levels.

Queued jobs are reducing in number and we continue to monitor.
Posted Jan 21, 2026 - 00:10 GMT

Investigating

We are investigating elevated processing times for Digitize jobs that use Gemini 2.5 Flash processors.

Error rates remain normal but processing durations may be longer than typical.
Posted Jan 20, 2026 - 23:52 GMT
This incident affected: Digitize Service.