Elevated Processing Times due to Google Cloud Platform (Gemini)

Incident Report for Cytora

Resolved

Response times have returned to expected levels and outstanding jobs processed.
Posted Feb 10, 2026 - 20:31 GMT

Monitoring

Response times are returning to expected levels. We continue to monitor closely.
Posted Feb 10, 2026 - 20:14 GMT

Identified

We are currently experiencing elevated digitize job processing times as a result of an increase in response times from Google Cloud Platform Gemini API requests.

Error rates remain unchanged with jobs completing with delay.

We are diagnosing with Google Cloud Platform and investigating possible mitigations.
Posted Feb 10, 2026 - 19:20 GMT
This incident affected: Digitize Service.