Elevated Processing Times US Region due to Google Cloud Platform (Gemini)

Incident Report for Cytora

Resolved

We have applied mitigation with Google Cloud Platform and processing times have returned to normal levels.

We continue to monitor.
Posted Jan 23, 2026 - 21:38 GMT

Monitoring

We have applied available mitigation steps on our end. We continue to observe degraded performance from Google Cloud Platform in the US region, which is impacting Digitize job processing times. We will keep monitoring and provide updates as the situation evolves.
Posted Jan 23, 2026 - 18:02 GMT

Investigating

We are investigating elevated processing times for Digitize jobs that use Gemini 2.5 Flash processors.
Posted Jan 23, 2026 - 16:40 GMT
This incident affected: Digitize Service.