Cloudflare issues with Cloudflare Dashboard and related APIs

Incident Report for Cytora

Resolved

Our teams are not detecting any further impacted records in the Risk Stream Service

We will now set this incident as Resolved, while we will keep monitoring for any potential recurrences.
Posted Dec 05, 2025 - 10:04 GMT

Monitoring

Cytora is aware of Cloudflare issues this morning that can impact a subset of our clients, causing possible delays when processing RiskStream records.

Cloudflare confirmed that a fix has been implemented, and are currently monitoring the results.
For the most up-to-date information please refer to: https://www.cloudflarestatus.com/

Meanwhile, our teams will continue monitoring for any impacted records and reprocess them where it is necessary.
Posted Dec 05, 2025 - 09:31 GMT
This incident affected: Risk Console and Risk Stream Service.