Elevated processing times

Incident Report for Cytora

Resolved

This incident has been resolved.

Please reach out to help@cytora.com for support in re-driving any affected jobs.
Posted Sep 21, 2026 - 16:37 BST

Monitoring

We have applied model routing mitigations and processing times are returning to expected durations. We continue to closely monitor.

Please reach out to help@cytora.com for support in re-driving affected jobs.
Posted Sep 21, 2026 - 16:21 BST

Identified

Some Digitize schema jobs (mostly containing longer documents) using the extract:005 processor are experiencing elevated processing times due to available model capacity. We are in the process of applying mitigations.
Posted Sep 21, 2026 - 16:09 BST

Investigating

Elevated processing times for some Digitize schema jobs.
Posted Sep 21, 2026 - 16:01 BST
This incident affected: Digitize Service.